Open links to jump to page content
Relay UK

Downloading the app

How to download the app for use with Relay UK.

1. Download the app

You can download the Relay UK app from Apple's App Store for iOS devices or download from Google Play for Android devices.

For Windows 10 PCs, you can Get Relay UK from the Microsoft Store.

If you don’t have a Windows 10 PC, or you want to join Relay UK calls from your Mac, for a limited time you can still install and use the NGT Lite app on your computer.

  • Available for Windows 7, 8 with Java 1.7 or later installed

     

    NOTE: The new Relay UK app is available for Windows 10 PCs (version 1809 or later). As an alternative you can continue to use NGT Lite with earlier Windows PCs but this version of the app is no longer supported.

     

    By downloading NGT Lite, you accept our 

    BT Applications Software Licence Agreement

     

    If you can't run the Window installer

    1. Download a zipped copy of the files.
    2. Extract the NGT Lite folder and all the files in the .zip into a suitable folder on your Windows PC.
    3. Double-click the NGT Lite.exe file to launch the app.

    See how to download NGT Lite on a Windows PC

  • Available for Intel-based Apple Macs running OS X 10.7.3 or later and with Java 1.7 or later installed

     

    NOTE: The new Relay UK app for Macs will be available soon. In the meantime, you can continue to use NGT Lite with your Desktop Computer

     

    By downloading NGT Lite, you accept our BT Applications Software Licence Agreement and understand this app version won’t be updated

    1. Download NGT Lite for Mac.
    2. Double-click to unarchive the file, then move to the Applications folder on your Mac.
    3. Double-click NGT Lite.jar to launch it.

    If you can’t run the app:

    1. If you get a Security notification after you launch NGT Lite.jar, check your ‘Security & Privacy’ settings in System Preferences and 'allow apps from anywhere'.
    2. When prompted, allow NGT Lite to run.

     

    Remember: NGT Lite is only recommended for use on Intel-based Mac Computers running OS X 10.7.3 or later